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 In lesson 1 we are going to use the desktop GIS application Quantum GIS (QGIS) to explore and 

map global climate and demographic data.  QGIS is an Open Source Geographic Information System 

and is officially a part of the Open Source Geospatial Foundation (OSGeo).  It runs on Linux, Unix, 

Mac, and Windows and is a powerful GIS for vector and raster data analysis and mapping.  To learn 

more about QGIS visit http://www.qgis.org/. 

 
In this first exercise, we will be working with global climate model output from the Community 
Earth System Model (CESM) in order to map possible future temperature and precipitation change 
by the middle of the 21st century.  We will map temperature change thresholds and identify which 
regions may be affected by these changes.  This first exercise will focus on global change. 

STEP 1 Exploring the QGIS interface 

 
Type in your working directory here.  This is the location in which you copied that course 
data. 
<your working directory> = ______________________________________________________________________ 
 

We will start off by exploring output from a global climate model (CCSM3) in QGIS. 

 Open the QGIS Desktop application. 

o  For Windows Start > All Programs > Quantum Dufour > Quantum GIS Desktop 

2.0.1 

o For Mac Open the Applications folder and click on QGIS. 

QGIS Desktop is a user friendly application for performing spatial data analysis, and making maps.  

We will now explore some of the features of QGIS. 

 When you open QGIS a QGIS Tip will appear.  Click OK to close this window. 

 

 

 

 

 

 

 

 

http://www.qgis.org/
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Below is the basic layout of the QGIS Desktop window.  There is a map legend (or Table of Content), 

toolbars, and a map view where the data is displayed. 

 

 Hover your mouse over the buttons on the tool bar to see what they do. 

On the toolbar you may see tools followed by >>.  This means that the toolbar is too large to fit in 

the area and it tells us that there are more tools associated with that toolbar.  In order to make 

more space for the toolbars we are going to be using we will turn off some toolbars which we will 

not be using in this course. 

      

 Click View > Toolbars. 

 Turn off the following toolbars:  Digitizing, and Label (see screenshot on the following 

page). 

Map View 

Map Legend 

(Table of 

Content) TOC 

 

Toolbars 



© 2015 UCAR. This is an open access article under the terms of the Creative Commons Attribution-
NonCommercial 3.0 Unported License, which permits all non-commercial use, distribution, and 
reproduction in any medium, provided the original work is properly cited. 
 

 

 

You can also move toolbars around the QGIS interface by clicking on the left-hand side of the 

toolbar and dragging the toolbar to a new location. 

 

 Rearrange your toolbars so that all the tools are visible. 

Now that the interface is less cluttered, we will start by adding data into QGIS Desktop and 

symbolizing it.  

 Click the Add Vector Layer button on the File toolbar (toolbar located on the left 

hand side of the Table of Content). 
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 In the dialog which appears make sure File is selected. 

 Click the Browse button. 

 Make sure that the file type is set to ESRI Shapefiles[OGR] (*.shp). 

 Navigate to <your working directory>\data and add cntry02.shp, then click Open. 

 Click Open again to add the layer to your map. 

The shapefile gets added to QGIS as a layer and is displayed using a default symbology.  You will see 

in your map view all of the countries in the world displayed using the same color.   
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STEP 2 Working with tables and selections in QGIS 

A powerful aspect of GIS is that each spatial feature (e.g. each country) is a row in a database and 

each row (e.g. country) can have many attributes associated with it in order to better describe the 

feature.  To explore attribute (non-spatial) information for this dataset, open the attribute table: 

 

 In the TOC, right click on the layer 
cntry02 . 

 Select  Open Attribute Table from 
the context menu.   

 

 

The attribute table for the dataset will open.   

 

 

 Click in the grey box numbered 0 (see red box shown on the screenshot above). 
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 You will see the entire row is highlighted. By selecting a feature in the table, you can also select this 

feature on the map (Finland): the polygon (e.g. country boundary) that you have selected is 

highlighted on the map.  Further, the number of selected features is noted along the top of the 

attribute table, where it says “Features total: 251, filtered: 251, selected:1”.  You can select ranges of 

features by holding down the “Shift” key and clicking another row, or by using the “Ctrl” button 

(Windows) or the Command button (Mac) to select and de-select multiple features.  Selection is a 

powerful tool in GIS and can be performed by location or non-spatial information available in the 

attribute table.   

 Position the attribute table so you can see the selected features on the map. 

 Back in the map view click on the Select Feature tool on the Attributes toolbar.   

HINT In order to see the Select tool you may need to click the >> beside the Identify tool 

.   

 

 

 Click the downward arrow beside the 

Select Single Feature  tool. 
 Choose Select Features by Rectangle 

. 
 Draw a box around a few countries in 

South America. 
 

 

 

 Position the QGIS Desktop map and the attribute table beside each other so you can see 

both windows. 

The selected features will appear highlighted on the map and in the attribute table.   
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 In the Attribute Table, click the Move Selection to top  button. 

Now the selected features are located at the top of your attribute table. 

 Click the button that says Show All Features.  A dropdown will appear.  Now click on Show 

Selected Features. 

 

Now you should only see the selected features in your attribute table. 

 The button at the bottom left now reads Show Selected Features.  Click this button and 

select Show All Features. 

 Click the Unselect All button in the Attribute table   
 Close the Attribute table window. 
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STEP 3 Working with qualitative symbology and the layer properties 

Quantum GIS contains the ability to create color ramps in order to suit your data symbology needs.   

 Right click on the layer cntry02 in your Table of Content (TOC) and select Properties in 

order to open the Layer Properties dialog box. 

The Layer Properties dialog box is the area where we can change the way our data is displayed 

(symbolized).   

 Click the Style options on the left hand side. 

Notice that right now every country (polygon) is displayed using the same color.   

 In the Style area move the Layer transparency slider towards the right.  Stop around 50%. 

 Click Apply. 

 Move the Layer transparency back to 0 and click Apply. 

 You will see another Transparency slicer below the Layer rendering. 

 Move this slider to 50% and click Apply. 

Do you notice the difference in the transparency?  The Layer transparency will make everything 

transparent, the fill and the outline.  The transparency below if for the fill only.  This region gives 

you the ability to manipulate the fill color, style, and transparency. 

 Change the fill color to a bleu and click Apply. 
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Another way to display Qualitative data is by displaying each unique polygon (country) with a 

unique color.   

 Click the Single Symbol drop down and select Categorized. 

 For Column select CNTRY_NAME 

 Back in the Layer Properties dialog box click the Classify button and click Apply. 

Notice that each unique entry in the CNTRY_NAME field has been categorized with a color. 

We have just explored using the single symbol and category symbology.  These two methods of 

symbolizing data work well for qualitative data.  Qualitative data can describe features but are not 

numerical in nature.  In the previous example country name is a qualitative attribute.   

 In the Layer Properties dialog box, xcange the Categorized back to Single Symbol. 

1. Click Simple fill in the Symbol layers box. 

2. Click the Solid drop down for the Fill style and select No Brush. 

 

 

 

1 

2 
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 Click Apply. 

Notice that the countries are now display as outlines with no fill color. 

 Click on the Labels option in the left hand side menu. 

Currently labels are turned off. 

 Click the Fields option. 

Notice the fields and their type definition. Each field is a column in the attribute table. 

 Click the General option. 

 Change the Layer name from cntry02 to Countries. 

 Click Apply. 

 Click the Display option. 

 Change the Field to CNTRY_NAME. 

 Click OK to save your changes and close the Layer Properties dialog box. 

Notice now that in the Table of Content (TOC) the countries layer name has changed. 

 Click the Identify   tool on the Attributes toolbar. 

 Place your mouse over Mexico and click.  

In the Identify dialog box the first field you see is CNTRY_NAME, this is the Display field you set in 

the properties. 

What is the population of Mexico?  (write your answer below) 

 

 Close the Identify dialog box. 

STEP 4 Working with quantitative symbology 

Quantitative data is numerical information, such as counts or measurements.  In this next step we 

will explore options for symbolizing quantitative data. 

 Click the Add Vector Layer  again, this time add the file temperatureChangeMid.shp 

from <your working directory>\data. 

The data in the map view are displayed from the bottom up. However, when you add new data to 

your map it will be placed as the top layer.  Since we added temperatureChangeMid.shp to our maps 

this data is now being displayed on top of the Countries layer. 
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 In the Table of Content (TOC), click the Countries layer and drag it above the 

temperatureChangeMid layer. 

The temperatureChangeMid layer contains information for each cell about the annual mean 

temperature change (in degrees Celsius) between the “present” (1986-2005) annual mean 

temperature and the middle of the 21st century (2040-2059) annual mean temperature as projected 

by CCSM using the RCP 8.5 emission scenario.  This dataset came from the NCAR Climate Change 

Scenarios Portal (http://GISClimateChange.ucar.edu).   

  

 Right click on the layer 

temperatureChangeMid in the map 

legend and choose  Open Attribute 

Table. 

 

 

 

 Find and click on the field “atas”. Notice an arrow appears which points up and the data is 

now sorted ascending.   
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 Click the field “atas” again to see the data sort descending. 

In the table, you will notice that in some areas temperature change exceeds 5 degrees Celsius.    

We will now symbolize temperatureChangeMid based upon the field atas in order to visually see 

where annual temperature change may be most severe. 

 

 Close the attribute table. 

 Double click on temperatureChangeMid in the Table of Content (TOC) in order to open the 

Layer Properties window. 

 Make sure the Style option is activated. 

 Change the drop down for Single Symbol to Graduated.   

 For Column select atas. 

Note that the colors are associated with data values from the attribute table. You can also choose 

the number of classes to display as well as the classification method (Mode). 

 Click the Change button for the Symbol option in order to open the Symbol selector. 
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 In the Symbol selector 

dialog box click the Simple 

fill Symbol layers. 

 Change the Border style 

from Solid Line to No Pen. 

This will eliminate any 

border from being 

displayed. 

 Click OK to close the 

Symbol properties box. 

 

 

 

 

 For Color ramp select OrRd. 

 Make sure the Mode is Equal Interval. 

 Click Classify. 

 Click Apply. 

 Take a look at your map. 

 Change the Mode to Quantile, click Apply. 
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Take a look at your map. 

 Play around with the different classification methods and colors available through the 

Mode drop-down. 

 

Below is a table with various other classifications and a description of each method: 

Natural Breaks Classes are based on natural groupings of data values (Jenk’s method) 

Quantile Each class contains an equal number of features. 

Equal interval Divides your data into equally spaced classes. 

Standard deviation Classifies the amount a feature’s attribute value varies from the mean. 

Pretty Breaks Breaks data into groups which are easily understood by non-statisticians. 

 

 Once you are done experimenting with the different classification methods, change the 

Mode to Natural Breaks. 

 Make sure the Classes are set to 10. 

 Make sure the Color ramp is OrRd. 

 Click OK to apply the changes. 

 
 

If the legend for this layer is not visible, then 

click the plus sign (Windows) and arrow (Mac) 

in the Table of Content (TOC) next to 

temperatureChangeMid to reveal the symbology 

of the layer. 
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This map illustrates the mean annual temperature change from the present to the middle of 

century.   This layer is symbolized using the natural breaks classification method.  The regions 

in darker red will experience more warming at the end of the century than those in lighter 

orange. 

 

 Then click the Zoom In  tool on the Navigation toolbar and draw a box around the 
continental United States. 

 
Which regions in the continental US according to this dataset appears will have some of the 
most warming come the middle of the century? 
 
 

 Click the Zoom Full tool in order to return to the full extent of the data. 
 
 
Which regions globally according to this dataset appears will have some of the most warming 
come the middle of the century? 
 
 
 

 Turn off the temperatureChangeMid layer, by unchecking the box beside the name 

temperatureChangeMid in the Table of Content (TOC). 

 

 Click Project > Save Project. 

 Save your map in <your working directory>\maps and name it exercise1. 
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STEP 5 Symbolize and Explore Precipitation Change 

In the previous step we added a shapefile which contained information about future temperature 

change. In this step we will explore future precipitation change.   

The data we are about to work with was downloaded from http://GISClimateChange.ucar.edu.  This 

data is freely available and is available in shapefile and textfile format.   

 Click the Add Vector Layer button on the main toolbar. 

 Click Browse and navigate to <your working directory>\data and select 

precipChangeMid.shp. 

 Right click on precipChangeMid in the TOC and select  Open Attribute Table. 

 

Notice that this shapefile contains one fields.  This field contains the precipitation change for the 

mean of 2040-2059 compared to present day (1986-2005).  This data is in mm/year. 

 

 Close the Attribute table. 

We are now going to symbolize the precipChangeMid layer based on the field “appt”. 

 Right-click on the layer precipChangeMid in your TOC and select Properties. 

 Make sure the Style option is activated. 

 Change the drop down from Single Symbol to Graduated. 

 For Column select appt 

 Click change… button 

 

http://gisclimatechange.ucar.edu/
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 In the Symbol properties dialog box, change the Border style from Solid Line to No Pen. 

 Click OK to close the Symbol properties box. 

 

 For Color ramp select RdBu. This is a red-to-blue color ramp. 

 Make sure the Mode is Standard Deviation. 
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 Change the number of Classes to 10. 

 Click OK. 

 Drag the layer countries above precipChangeMid in the TOC, if it is not on top already. 

 Take a look at your map. 

The regions in dark red may experience a much drier climate in the future, while those in blue may 

receive more annual precipitation in the future 

QGIS also has some powerful query tools.  We can set up a Structured Query Language (SQL) query 

to see what regions are going to experience different magnitude of climate change. 

 Right click on the layer precipChangeMid and select Filter… 

 

 In the dialog which appears 

double-click on appt so 

that it appears in the SQL 

where clause box. 

 Click on <. 

 Click on the SQL where 

clause text box. 

 Type in 0. 

Your SQL statement should 

look like the one to the right.  

 Click the Test button to 

test the query and find out 

how many features are 

returned. 

 Click OK to run the query 

builder. 

 

 

The only data you will see on your map are those features which matched the query.  These regions 

are areas which may experience a decrease in precipitation at the middle of the 21st century. 

 Using the skills you have already learned change the symbology for precipChangeMid from 

Standard Deviation to Natural Breaks Mode.  (HINT: Look in the Layer Properties) 

 Change the Color ramp to RdYlBu and click Classify. 

 Click OK. 

 Use the Zoom In Tool on the Navigation toolbar zoom into the Americas. 
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Now the areas in red will have the most drying and those in blue will still have drying but less 

drying.  Remember you are only see data which will have a dryer future climate according to the 

climate model.  The area in white are those regions which may have a wetter climate. 

Where do you see some of the most drying in the Americas?  (Zoom in if needed) 

 

 Right-click on precipChangeMid layer in your TOC and select Filter… 

 Change your query to see what regions may experience negative annual precipitation 

anomalies (drying) more than 50 mm (ppt_change < -50) (HINT: Clear your previous 

expression). 

 Click to the Zoom Full tool  

 

Where do you see some of the most drying globally?  

 

 Right-click on precipChangeMid in the TOC and select Filter… 

 Click Clear. 

 Click OK. 

Since we have symbolized our data using Natural Breaks when we had a filter active, only the data 

which matched that query was used in the classification method for symbolizing our data.  So now 

that we have cleared the query we still only see the data which matched our SQL query.  

 Double click on precipChangeMid in your TOC and change the symbology Mode to Pretty 

Breaks. 

 Change the Color Ramp to RdYlBu. 

 Click Classify. 

 Click Ok. 

 

Step 6 – Identify regions of warming and drying 
Next we will join the temperature change and the precipitation change datasets together in order to 

identify regions which may see a warming and drying by the middle of the 21st century. 

 

 Click Vector > Data Management Tools > Join attributes by location. 



© 2015 UCAR. This is an open access article under the terms of the Creative Commons Attribution-
NonCommercial 3.0 Unported License, which permits all non-commercial use, distribution, and 
reproduction in any medium, provided the original work is properly cited. 
 

 

 

 In the dialog set the following parameters:  precipChangeMid as the Target vector layer. 

 Set temperatureChangeMid as the Join Vector layer. 

 Make sure “Take attributes of first located features is selected”. 

 Save the output shapefile to <your working 

directory>\data\results\precipTempChange.shp. 

 Once the dialog looks like the one below, click OK. 



© 2015 UCAR. This is an open access article under the terms of the Creative Commons Attribution-
NonCommercial 3.0 Unported License, which permits all non-commercial use, distribution, and 
reproduction in any medium, provided the original work is properly cited. 
 

 

 Click Yes when asked to add this new layer to your map. 

 Close the dialog box. 

A new layer is now added to the TOC. 

 Make sure the only two layers which are turned on are Countries and precipTempChange. 

 Right click on the layer precipTempChange in the TOC and select Open Attribute Table. 

 In the Attribute table click the select features using an expression button.  

 

 

 In the Select By Expression dialog scroll to the bottom of the Function List box and open the 

Fields and Values option. 
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You should see both the variable apt (precipitation change) and atas (temperature change). 

 Double-click on atas in the fields list. 

Make sure you see “atas” appear in the SQL where clause text box. 

 In the Function List Open the Operators option and double click >=. 

 Click in the SQL where clause and type in 2. 

 Double click AND. 

 Back in the Fields and Values options, double click appt. 

 Double click <=  

 Type in 0. 

 Your expression should look like the one below. 

 

 

 Once your expression looks like the one above click the Select button.   

 Click Close. 

 You should have 1391 features selected on your map and table.  The grid cells highlighted in 

yellow are those which may experience greater than 2 degrees warming and drying by the 

middle of the 21st century.  

 Close the Attribute table. 
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 Right-click on 

precipTempChange  in your TOC 

and select Save Selection As…. 

 In the Save vector layer as… 

make sure the Format is set to 

ESRI shapefile. 

 Click the Browse button to set 

he Save as file. 

 Navigate to <your working 

directory>/data/results and 

type in the output file name to 

be warmAndDry.shp 

 Click Save. 

 Make sure the Add saved file to 

map is checked. 

 

 Click OK to save your output 

selected grid cells to a new 

shapefile. 

 

 

 

 

The warmAndDry shapefile has all the grid cells where the temperature change may be 2 degrees 

or greater by the middle of the century and which may experience drying.   

 

Which regions may experience this warming and drying by the middle of the 21st century? 

 

 

What may be some impacts from this change in climate in these regions? 
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 Save your project. 

Step 7 – Identify which crops are currently within this region of possible 

future warming and drying 
 

 Click the Add Vector Layer button on the main toolbar. 

 Click Browse and navigate to <your working directory>\data and select crops.shp. 

 Right click on crops in the TOC and select  Open Attribute Table. 

This shapefile are 0.5 degree grids in shape.  Each attribute is a crop type.  The values for each row  

tell us the fraction that this crop is grown in that grid cell.  First let us symbolize the layer crops for 

a few types of crops. 

 Close the Attribute table. 

 Double click on the layer crops and make sure the General option is selected. 

 We will set up a Feature subset so that we are only mapping features which contain some level 

of Soy agriculture. 

 Click the Query Builder button in the Feature subset section of the dialog box. 

 



© 2015 UCAR. This is an open access article under the terms of the Creative Commons Attribution-
NonCommercial 3.0 Unported License, which permits all non-commercial use, distribution, and 
reproduction in any medium, provided the original work is properly cited. 
 

 
 In the Fields double click on Soy so that it appears in the expression box. 

 Click “!=” 

 And type in -9999. 

 Once your expression looks like the one above click OK. 

 Back in the Layer Properties click Apply. 

This expression will virtually remove all features which have the value of -9999 from our visual display.  

This means that we will now map only those features which have some soy agriculture. 

 Click the Style option. 

 Change the way we will symbolize the data from Single Symbol to Graduated. 

 Change the Column to Soy. 

 Change the Color Ramp to Greens 

 Click the Change… button  

 In the Symbol Selector click the Simple fill option and change the Border Style to No Pen. 

 Click OK to close the Symbol Selector. 

 Click OK to apply the symbolige and close the Layer Properties dialog box. 

Where are some of the highest concentrations of Soy agriculture? 
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 Turn on the layer warm and Dry. 

Does the highest regions of Soy agriculture correspond with the regions which may experience 

the most warming and drying? 

 

An easier way to identify what crops fall within the region of warming and drying is to perform a 

process called Intersect.  An Intersect will take two layers and extract all features from one layer 

which intersect the second layer.  In this case our first layer will be crops (this is the layer we wish 

to extract) and we want to extract all crop grids which intersect with the warmAndDry layer. 

 Double click on the layer crops in order to open the Layer Properties box. 

 In the General Option click Query Builder. 

 Click Clear in order to clear the query, and click OK. 

 Click OK again to close the Layer Properties dialog box. 

 Click Vector > Geoprocessing Tools > Intersect. 

 

 

 In the Intersect tool set the Input vector layer to crops and set the Intersect layer to 

warmAndDry.  

 For the output shapefile save the new file to <your working directory>\data\results and 

call it WarmDryCrops.shp. 

 Click Ok to run the tool. 
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This tool will extract all polygons from the layer crops which intersect with the warmAndDry layer.  

So the resulting shapefile will be all crop polygons which may have a warmer and dryer future 

according to the CESM climate model. 

 When asked say Yes to adding the new layer to your map. 

 Close the Intersect tool. 

 Turn off the layers crops and warmAndDry.  The only layers you need to have turned on are 

Countries and warmDryCrops. 

Using the skills you have learned in this lesson symbolize WarmDryCrops using Graduated Colors 

for some of the different crop types.  Experiment symbolizing using different methods such as Equal 

Interval, Standard Deviation, Pretty and using different color ramps. 

Working with the symbology answer the questions below. 

What may be some impacts from this warming and drying on crops in the United States? 

 

 

Which crops are found in the warming and drying regions of Europe? 

 

 

 Once you are happy with your maps Save your map and close QGIS. 

 

Summary : In exercise 1 we learned how to add vector data to QGIS.  We symbolized vector data 

based on qualitative and quantitative fields.  Using the Filter and Selection tools we were able to see 

the range of possible temperature and precipitation change a region may experience.  And finally 

using QGIS’s advanced integration tools we were able to see which regions and crop types may be 

affected by a 2 degree temperature increase and a drying by the middle of the century. 


